Bug#667053: should divert config_data manpage too

Niko Tyni ntyni at debian.org
Tue Apr 3 18:26:18 UTC 2012

Package: libmodule-build-perl
Version: 0.400000-1
Severity: minor

This package should divert /usr/share/man/man1/config_data.1.gz
from perl away in favour of its own, supposedly newer version,
/usr/share/man/man1/config_data.1p.gz. Otherwise the man search
path will prefer the older version by default.

See #474529; quoting Colin Watson there:

> It's almost always wrong to handle manual pages differently from
> binaries in maintainer scripts - if you divert foo to foo.real, you
> should also divert foo.1.gz to foo.real.1.gz. (Similarly for
> alternatives.)

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=fi_FI.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libmodule-build-perl depends on:
ii  libcpan-meta-perl               2.120630-1
ii  libmodule-metadata-perl         1.000009-1
ii  libperl-ostype-perl             1.002-1
ii  libversion-perl                 1:0.9700-1
ii  perl                            5.14.2-9
ii  perl-modules [libversion-perl]  5.14.2-9

Versions of packages libmodule-build-perl recommends:
ii  libmodule-signature-perl            0.68-1
ii  libpod-readme-perl                  <none>
ii  libsoftware-license-perl            0.103004-2
ii  perl-modules [libarchive-tar-perl]  5.14.2-9

libmodule-build-perl suggests no packages.

-- no debconf information

More information about the pkg-perl-maintainers mailing list