Bug#653792: clive: Clive fails to download with secured YouTube video URLs.

Ansgar Burchardt ansgar at debian.org
Sun Jan 1 14:35:22 UTC 2012

fixed 653792 2.2.21-1
found 653792 2.3.2-1

Ant <ant at zimage.com> writes:
> $ clive https://www.youtube.com/watch?v=eNVsXgvvOnQ
> fetch http://https://www.youtube.com/watch?v=eNVsXgvvOnQ ...
> error: Couldn't resolve host name (http/6)
> Non-secured URLs worked though.

Hmm, this was fixed upstream in 2.2.20 [1], but in 2.3 it appears to be
broken again:

% clive "https://www.youtube.com/watch?v=eNVsXgvvOnQ"                       
Checking ...WARNING: gnome-keyring:: no socket to connect to
warning: --category-http: deprecated, use --category instead
warning: --quiet: deprecated, use --verbosity instead
error: Couldn't resolve host name (http/0, conn/0, curl/6)

It works when not using SSL.

quvi however reports the correct URL:

% /usr/bin/quvi --category http 'https://www.youtube.com/watch?v=eNVsXgvvOnQ'
WARNING: gnome-keyring:: no socket to connect to
:: Check for URL redirection ...done.
:: Fetch config ...done.
:: Verify media URL ...done.
  "host": "youtube",
  "page_title": "The Worlds Greatest Prankster 2011 - PART 1",
  "page_url": "https://www.youtube.com/watch?v=eNVsXgvvOnQ",
  "id": "eNVsXgvvOnQ",
  "format_requested": "default",
  "thumbnail_url": "https://i2.ytimg.com/vi/eNVsXgvvOnQ/default.jpg",
  "duration": "930000",
  "link": [
      "id": "1",
      "length_bytes": "37517542",
      "content_type": "video/x-flv",
      "file_suffix": "flv",
      "url": "http://o-o.preferred.fra07s01.v11.lscache5.c.youtube.com/videoplayback?sparams=id%2Cexpire%2Cip%2Cipbits%2Citag%2Csource%2Calgorithm%2Cburst%2Cfactor%2Ccp&fexp=912208%2C916103%2C906930%2C913101&algorithm=throttle-factor&itag=5&ip="

I can then download the video with wget (although there is a 302
redirect to another host).


[1] <http://sourceforge.net/apps/trac/clive/ticket/3>

More information about the pkg-perl-maintainers mailing list