Bug#674395: libdbd-mysql-perl: FTBFS: ld: cannot find -lssl

gregor herrmann gregoa at debian.org
Thu May 24 12:38:59 UTC 2012

On Thu, 24 May 2012 14:23:17 +0200, Salvatore Bonaccorso wrote:

> Can confirm this, and adding libssl-dev to Build-Depends solves the

I haven't looked yet, but this seems new ... Can this be related to
changes in libmysqlclient-dev from 5.1 to 5.5?
mentions SSL stuff at some points ...

(Random factoid: Lucas' rebuild was against
libmysqlclient-dev 5.5.23-2, yesterday 5.5.23+dfsg-1 was uploaded
with the changelog entry:
   * Revert having libssl-dev as a build dependency and changed
     WITH_SSL option to 'bundled' from 'yes' (Closes: #590905)
     and (Closes: #673865)

Luckily periapt is involved here and there and might know better
what's going on :)


 .''`.  Homepage: http://info.comodo.priv.at/ - OpenPGP key 0xBB3A68018649AA06
 : :' : Debian GNU/Linux user, admin, and developer  -  http://www.debian.org/
 `. `'  Member of VIBE!AT & SPI, fellow of the Free Software Foundation Europe
   `-   No more blah, blah, blah!  -- Kirk, "Miri", stardate 2713.6 

More information about the pkg-perl-maintainers mailing list