[Pkg-phototools-devel] Bug#682616: Chromium keeps crashing with segfaults

Emmanuel Bouthenot kolter at openics.org
Sat Jul 28 09:42:30 UTC 2012

On Sat, Jul 28, 2012 at 12:21:54PM +0300, Onur Aslan wrote:
> We know this bug occurred when we upgrade libexif to 0.6.20-3. One of that
> security patch broke the package.
> Instead of downgrading libexif to 0.6.20-2, I made a package for 0.6.21. It
> includes security fixes and chromium crashes are gone.
> You can get it here and use it until libexif maintainers fix the package:
> http://i.onur.im/libexif/
That would have been easy but Security Team explicitly asked to fix the
security issues by backporting the needed patches (see #681454).

> And I believe, this bug must be grave. It simply makes chromium unusable.
The main problem here is that there is now way to reproduce this bug (at
least for me).

I'd like to get a real gdb backtrace which shows that the bug is related
to libexif.



Emmanuel Bouthenot
  mail: kolter@{openics,debian}.org    gpg: 4096R/0x929D42C3
  xmpp: kolter at im.openics.org          irc: kolter@{freenode,oftc}

More information about the Pkg-phototools-devel mailing list