Bug#413447: [php-maint] Bug#413447: Etch upgrade divide php-pear into several packages without warning

Aurélien Le Provost - Ribaltchenko aurelien at aurelp.fr.eu.org
Sat Mar 10 01:51:54 CET 2007


Le mercredi 7 mars 2007 23:08, vous avez écrit :

> > After a while I carried out the origin of the problem : in my
> > case I must install php-log and php-db at least.
> >
> > Perhaps other people will save time if apt-listchanges notice
> > them about the cutting of php-pear?
> i'm curious how you found yourself in this position.  currently in
> etch there is a php4-pear package which depends on php-pear plus
> all of the modules that used to be contained by php4-pear (php-db,
> etc).  btw, php-log was never part of php4-pear, and was a seperate
> package (php4-pear-log).

Yep but the sarge to etch upgrade I decided to upgrade from php4 to 
php5. Despite the php-pear replaces "php4-pear (<< 4:4.4.0-0)", it 
only depends of  "php5-cli | php4-cli, php5-common", not php-db, 
php-log etc. These packages should at least belong to the package 

> did you remove the php4-pear package before upgrading?

Yes : as I said I decided to switch to php5, so for me it's mean purge 
all php4 package since I will not use them anymore. Also, when I do 
dist-upgrade and that I see a package or many which will be removed, 
I stop and purge it.

aurelien|~% dpkg -l |grep ^rc                                 1:20

> you should probably file a  seperate bug report against this to the
> php-log package, which is maintained by someone outside the debian
> php maintainers group

Okay, I will make it in the days coming.


Mail et newgroups : pourquoi et comment citer un message, infos à
propos du langage SMS, sur les pièces jointes, ...

More information about the pkg-php-maint mailing list