[php-maint] php5-mysql Broken packages

Javier Odom javier at odomit.com
Fri Mar 21 18:06:46 UTC 2008

Hash: SHA1


Can you point me in the right direction for a fix for the following:

~# apt-get install php5-mysql
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
~  php5-mysql: Depends: phpapi-20060613+lfs
~              Depends: php5-common (= 5.2.0-8+etch10) but
5.2.5-0.dotdeb.1 is to be installed
E: Broken packages

Here is what i get when i attempt to build-dep:

# apt-get build-dep php5-mysql
Reading package lists... Done
Building dependency tree... Done
The following NEW packages will be installed
~  apache-common apache-dev apache2-prefork-dev autoconf automake1.4
autotools-dev chrpath comerr-dev debhelper
~  defoma firebird2-common firebird2-dev fontconfig fontconfig-config
freetds-dev gettext html2text
~  intltool-debian libapr1-dev libaprutil1-dev libaspell-dev libaspell15
libaudio2 libbz2-dev libc-client-dev
~  libc-client2002edebian libct3 libcurl3-openssl-dev libdb4.4-dev
libexpat1-dev libfbclient1 libfbembed1
~  libfontconfig1 libfontconfig1-dev libfreetype6 libfreetype6-dev
libgcrypt11-dev libgd2-xpm libgd2-xpm-dev
~  libgpg-error-dev libice-dev libidn11-dev libjpeg62-dev libkadm55
libkrb5-dev liblcms1 libltdl3-dev
~  libmcrypt-dev libmcrypt4 libmhash-dev libmhash2 libmng1
libodbcinstq1c2 libpam0g-dev libpcre3-dev libpcrecpp0
~  libpng12-dev libpq-dev libpspell-dev libqt3-mt librecode-dev
librecode0 libsensors-dev libsensors3 libsm-dev
~  libsnmp-base libsnmp-perl libsnmp9 libsnmp9-dev libsqlite0
libsqlite0-dev libsqlite3-dev libsybdb5 libsysfs2
~  libt1-5 libt1-dev libtidy-0.99-0 libtidy-dev libtool libwrap0-dev
libx11-dev libxau-dev libxcursor1
~  libxdmcp-dev libxext-dev libxfixes3 libxft2 libxi6 libxinerama1
libxml2-dev libxmltok1 libxmltok1-dev
~  libxpm-dev libxrandr2 libxrender1 libxslt1-dev libxslt1.1 mlock
odbcinst1debian1 pkg-config po-debconf re2c
~  ttf-dejavu unixodbc unixodbc-dev uuid-dev x11proto-core-dev
x11proto-input-dev x11proto-kb-dev
~  x11proto-xext-dev xtrans-dev
0 upgraded, 111 newly installed, 0 to remove and 0 not upgraded.
Need to get 39.1MB of archives.
After unpacking 108MB of additional disk space will be used.
Do you want to continue [Y/n]? n

My primary concern with continuing with the above build-dep is that i am
running Apache2, and do not want to overwrite with Apache.

# dpkg -l | grep apache
ii  apache2                   2.2.3-4+etch4                        Next
generation, scalable, extendable web se
rc  apache2-common            2.0.54-5sarge1                       next
generation, scalable, extendable web se
ii  apache2-mpm-prefork       2.2.3-4+etch4
Traditional model for Apache HTTPD 2.1
ii  apache2-utils             2.2.3-4+etch4
utility programs for webservers
ii  apache2.2-common          2.2.3-4+etch4                        Next
generation, scalable, extendable web se
ii  libapache2-mod-php5       5.2.5-0.dotdeb.1
server-side, HTML-embedded scripting languag

Any help would be appreciated!

.javier odom (480.734.4188)
Odom InfoTech - http://www.odomit.com
Version: GnuPG v1.4.8 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the pkg-php-maint mailing list