[Pkg-postgresql-public] Moving from PostgreSQL 9.0 to 9.1 in sid

Martin Pitt mpitt at debian.org
Sun Aug 21 09:38:35 UTC 2011

Hello all,

PostgreSQL 9.1 RC1 will be released next Monday, and as the final
version is not far any more and we need widespread testing, I plan to
upload it to unstable now (betas have been in experimental as usual).

Considering Debian's and PostgreSQL's release frequencies, I think
that Wheezy will ship with 9.1. This will give us enough time to
provide the packaged server-side extensions for 9.1 and clean up the
remaining reverse dependencies of 9.0 and 8.4.

9.0 has never been in a stable release and has only a few rdepends.
The reverse dependencies of p-server-dev-9.0 are:


Binary-only depends are:

   gforge-db-postgresql (Source: fusionforge)
   postgresql-9.0-pgfincore (Source: pgfincore)
   postgresql-9.0-pgmp (Source: postgresql-pgmp)
   postgresql-9.0-pljava-gcj (Source: postgresql-pljava)

(I also sent this message to the maintainers). It would be great if
you could prepare packages which only build against PostgreSQL 9.1, so
that unstable users can test their setups against 9.1 and that we can
remove 9.0 from unstable/testing soon.

There is also a bunch of packages which only have binary dependencies.
For these I recommend to only depend on the versionless metapackages
instead, this avoids having to update them for each major version:

  Package: bucardo
  Depends: adduser, perl (>= 5.10.0), libdbix-safe-perl, libdbd-pg-perl
  Recommends: postgresql-plperl-8.4 | postgresql-plperl-9.0
  Package: davical
  Depends: debconf (>= 1.0.32), php5-pgsql, postgresql-client-9.0 | postgresql-client-8.4 | postgresql-client-8.3 | postgresql-client-8.2 | postgresql-client-8.1, libawl-php (= 0.46-1), libdbd-pg-perl, libyaml-perl
  Recommends: postgresql (>= 8.1)
  Package: gforge-db-postgresql
  Depends: gforge-common, postgresql (>= 8.1) | postgresql-9.0 | postgresql-8.4 | postgresql-8.3 | postgresql-8.2 | postgresql-8.1 | postgresql (>= 8.1), perl, libdbi-perl, libdbd-pg-perl, libmime-base64-perl, libhtml-parser-perl, libtext-autoformat-perl, libmail-sendmail-perl, libsort-versions-perl, debianutils (>= 1.7), debconf (>= 1.0.32) | debconf-2.0, ucf, php5-cli, php5-pgsql, php-htmlpurifier

At the same time I'll file bugs against packages to move from 8.4 to

Does that work for everybody?

Thank you,

Martin Pitt                        | http://www.piware.de
Ubuntu Developer (www.ubuntu.com)  | Debian Developer  (www.debian.org)

----- End forwarded message -----

Martin Pitt                        | http://www.piware.de
Ubuntu Developer (www.ubuntu.com)  | Debian Developer  (www.debian.org)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 836 bytes
Desc: Digital signature
URL: <http://lists.alioth.debian.org/pipermail/pkg-postgresql-public/attachments/20110821/6ce274e7/attachment.pgp>

More information about the Pkg-postgresql-public mailing list