Bug#610081: pulseaudio: Pulseadio not working well with audigy 2 value 7.1 sound card

michael flinkdeldinky at yahoo.com
Sat Jan 15 10:26:19 UTC 2011

Package: pulseaudio
Version: 0.9.21-3+b1
Severity: important

My Audigy2 value 7.1 card works fine with the alsa driver and apps (such as
vlc) and vlc is able to do 7.1 sound.

However, Pulseaudio claims to see my Audigy2 value card and the mixer shows all
the channels but I only get front-right and front-left through my front-center
speaker when I run the command:
speaker-test -c 8 -t wav

On the Gnome Sound Preferences application on the Hardware tab I've got it set
to Analog Suround 7.1 Output + Analog Stereo Input (I've tried many other sound
profiles but output is always the same). On the Output tab my output device
selected (my only choice)  is: SB400 Audigy2 Value Analog Surround 7.1

My gigabyte motherboard has an Nvidia sound chip but it only worked in stereo
in alsa (eventhough it's a 7.1 chip) so I disabled it in the BIOS although
lspci seems to find it anyway.

-- System Information:
Debian Release: 6.0
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages pulseaudio depends on:
ii  adduser                 3.112+nmu2       add and remove users and groups
ii  consolekit              0.4.1-4          framework for defining and trackin
ii  libasound2              1.0.23-2.1       shared library for ALSA applicatio
ii  libc6                   2.11.2-7         Embedded GNU C Library: Shared lib
ii  libcap2                 1:2.19-3         support for getting/setting POSIX.
ii  libdbus-1-3             1.2.24-4         simple interprocess messaging syst
ii  libgdbm3                1.8.3-9          GNU dbm database routines (runtime
ii  libice6                 2:1.0.6-2        X11 Inter-Client Exchange library
ii  libltdl7                2.2.6b-2         A system independent dlopen wrappe
ii  libpulse0               0.9.21-3+b1      PulseAudio client libraries
ii  libsamplerate0          0.1.7-3          Audio sample rate conversion libra
ii  libsm6                  2:1.1.1-1        X11 Session Management library
ii  libsndfile1             1.0.21-3         Library for reading/writing audio 
ii  libspeexdsp1            1.2~rc1-1        The Speex extended runtime library
ii  libudev0                164-3            libudev shared library
ii  libx11-6                2:1.3.3-4        X11 client-side library
ii  libxtst6                2:1.1.0-3        X11 Testing -- Record extension li
ii  lsb-base                3.2-23.2squeeze1 Linux Standard Base 3.2 init scrip
ii  udev                    164-3            /dev/ and hotplug management daemo

Versions of packages pulseaudio recommends:
ii  gstreamer0.10-pulseaudio     0.10.24-1   GStreamer plugin for PulseAudio
ii  libasound2-plugins           1.0.23-1+b1 ALSA library additional plugins
ii  pulseaudio-esound-compat     0.9.21-3+b1 PulseAudio ESD compatibility layer
ii  pulseaudio-module-x11        0.9.21-3+b1 X11 module for PulseAudio sound se

Versions of packages pulseaudio suggests:
pn  paman                        <none>      (no description available)
pn  paprefs                      <none>      (no description available)
ii  pavucontrol                  0.9.9-1     PulseAudio Volume Control
pn  pavumeter                    <none>      (no description available)
ii  pulseaudio-utils             0.9.21-3+b1 Command line tools for the PulseAu

-- no debconf information

More information about the pkg-pulseaudio-devel mailing list