[Pkg-puppet-devel] Bug#484724: puppet: "User" type fails to update GECOS when not also updating UID

Nick Phillips nwp at debian.org
Thu Jun 5 21:42:12 UTC 2008

Package: puppet
Version: 0.24.4-5
Severity: normal


It seems puppet passes "incorrect" options to usermod when attempting to update
GECOS but not make any other changes. The "-o" option to usermod (to allow duplicate
user ids) causes usermod to fail if the "-u" option is not present (which, when
not modifying UID, it is not).

It would be fairly simple to either always pass UID to usermod, or to make the use
of "-o" conditional on use of "-u", but ruby isn't my strong point so I'll leave it
to someone who will make a neater job of it.

I think the usermod provider code also fails to quote the contents to be placed in
the GECOS field, despite a comment indicating that it is necessary (it is), and
similar code elsewhere in puppet doing so. But it could be that it's been sneakily
quoted elsewhere and I didn't spot it; as I said, ruby is not my first language ;-)

-- System Information:
Debian Release: 4.0
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: powerpc (ppc64)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-5-powerpc64
Locale: LANG=en_NZ.UTF-8, LC_CTYPE=en_NZ.UTF-8 (charmap=UTF-8)

Versions of packages puppet depends on:
ii  adduser                3.102             Add and remove users and groups
ii  facter                 1.3.5-1           a library for retrieving facts fro
ii  libopenssl-ruby        1.0.0+ruby1.8.2-1 OpenSSL interface for Ruby
ii  libshadow-ruby1.8      1.4.1-7           Interface of shadow password for R
ii  libxmlrpc-ruby         1.8.2-1           XML-RPC support for Ruby
ii  lsb-base               3.1-23.2etch1     Linux Standard Base 3.1 init scrip
ii  ruby                   1.8.2-1           An interpreter of object-oriented 

Versions of packages puppet recommends:
ii  rdoc                          1.8.2-1    Generate documentation from ruby s

-- no debconf information

More information about the Pkg-puppet-devel mailing list