[Pkg-puppet-devel] Bug#558815: Bug#558815: Bug#558815: puppet : no certificate to sign between a squeeze puppet and a Lenny's puppetmaster

Angus Frinc angus.frinc at free.fr
Tue Dec 1 09:27:20 UTC 2009

Le 01/déc - 00:48, Russ Allbery a écrit :
> Angus Frinc <angus.frinc at free.fr> writes:
> > What does it mean ?
> > Puppet which is able to push configuration for different distros and OS
> > isn't capable for different version of Debian ?
> > Is it mean that I need to upgrade my server in testing to be compatible
> > with my desktops flavor ?
> The Puppet 0.25 client, on any architecture or operating system, cannot
> talk to a Puppet 0.24 server, on any architecture or operating system.
> It's not supported and doesn't work.  If you want to deploy 0.25 clients,
> you need to first upgrade the server to 0.25.
> It has nothing to do with Debian specifically.  Upstream only supports
> compatibility between a new server and an old client, not the other way
> around.

OK, thank you for the precisions, you can close the bug report.
Sorry for the derangement.


More information about the Pkg-puppet-devel mailing list