[Pkg-puppet-devel] Bug#512639: puppetmaster should recommend libldap-ruby1.8

Thijs Kinkhorst thijs at debian.org
Thu Jan 22 12:57:14 UTC 2009

Package: puppetmaster
Version: 0.24.5-3
Severity: minor


When using puppetrun, the user is presented with an error message every time
if he doesn't have libldap-ruby1.8 installed, even if you don't use LDAP:

| # puppetrun --host example1.example.com
| Failed to load ruby LDAP library. LDAP functionality will not be available
| Finished

This is simply solved by installing that package. In order to avoid the
error, puppetmaster could Recommend libldap-ruby1.8. From what I read in
the docs it's a deliberate choice to display this warning when LDAP
support is not available.


-- System Information:
Debian Release: 5.0
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-1-686 (SMP w/1 CPU core)
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/bash

Versions of packages puppetmaster depends on:
ii  facter                        1.5.1-0.1  a library for retrieving facts fro
ii  lsb-base                      3.2-20     Linux Standard Base 3.2 init scrip
ii  puppet                        0.24.5-3   centralised configuration manageme
ii  ruby                          4.2        An interpreter of object-oriented 

Versions of packages puppetmaster recommends:
ii  rails                         2.1.0-6    MVC ruby based framework geared fo
ii  rdoc                          4.2        Generate documentation from ruby s

Versions of packages puppetmaster suggests:
ii  apache2-mpm-prefork [apa 2.2.9-10+lenny1 Apache HTTP Server - traditional n
pn  mongrel                  <none>          (no description available)

-- no debconf information

More information about the Pkg-puppet-devel mailing list