[Pkg-puppet-devel] Bug#651501: facter: dmidecode not needed on virtualized systems

Florian Ernst florian_ernst at gmx.net
Fri Dec 9 08:18:16 UTC 2011

Package: facter
Version: 1.6.4-1
Severity: normal

Hello there,

virtualized systems like LXC, OpenVZ or VServ won't be able to make use
of dmidecode at all, for them it will be just a useless dependency.

Furthermore, in facter, only
call dmidecode, and in both cases only if running on a physical system
or if dmidecode is indeed present.

Please consider lowering the Depends on dmidecode to a Recommends or
even a Suggests, considering that dmidecode is Priority: Important and
will most probably be installed on physical systems by other policies.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
URL: <http://lists.alioth.debian.org/pipermail/pkg-puppet-devel/attachments/20111209/2dfbc05e/attachment.pgp>

More information about the Pkg-puppet-devel mailing list