[DRE-commits] [ruby-aruba] annotated tag v0.7.0 created (now f8f5bbf)

Hideki Yamane henrich at moszumanska.debian.org
Fri Nov 20 13:33:19 UTC 2015


This is an automated email from the git hooks/post-receive script.

henrich pushed a change to annotated tag v0.7.0
in repository ruby-aruba.

        at  f8f5bbf   (tag)
   tagging  f7cdecd1626a9bdaff66d674a7b3627c88ddf4d5 (commit)
  replaces  v0.6.2
 tagged by  Max Meyer
        on  Thu Jul 2 22:27:57 2015 +0200

- Log -----------------------------------------------------------------
Version 0.7.0

Bradley Temple (1):
      Updating Vendored JQuery

Dennis Günnewig (86):
      Use new travis build infrastructure
      Tests for touch_file + mtime
      Pass through options to FileUtils to make it possible to set mtime
      Add tests for multiple files and refactor test for touch_file
      Refactor touch_file
      Add support for multiple files in *filesystem_permissions and split up tests for check and set permissions
      Add support for multiple files in remove_file and improve specs
      Make sure it exists and is a file
      Add support for multiple directories in remove_dir and improve specs
      Use rspec custom matcher for file comparism
      Fixed type in error messages
      Refactor tests for file comparism
      Rename *dir to *directory
      Added documentation for fixtures
      Added specs for fixtures-methods
      Added implementation for fixtures in aruba
      Make aruba-api creation reusable
      Added tests for matcher
      Added implementation for matcher
      Added test for file content matcher
      Added implementation for file matcher
      Remove private flag to add this matcher to the public api
      Added documentation
      Rename matcher to prevent problems with capybara matcher have_content
      Add tests to test new directory steps
      Changed steps to relax the use of "file/directory named"
      Make matcher public
      Added documentation for mode matcher
      Added documentation to include_regexp_matcher
      Ignore yardoc files generated during doc generation
      Added a proper .yardopts file
      Added file existence matcher
      Replace exist? throught file?
      Add matcher for directory existence as well
      Return all paths in current_directory
      Add matcher to check if path(s) matches pattern
      Add matcher for path existence
      Replace check_file_presence everywhere
      Deprecate include_regexp-matcher it was introduced as util-matcher and is not needed anymore.
      Add license finder to check licenses of aruba
      Ruby 1.9.3 is EOL https://www.ruby-lang.org/en/news/2015/02/23/support-for-ruby-1-9-3-has-ended/
      Add pry to make debugging of aruba a lot of easier
      Jruby 2 and 2.1-mode are not supported yet but should be
      Add deprecation warning to gemspec for ruby 1.9.3
      Added commands to CONTRIBUTING-guide
      Use bootstrap script in travis and pass it some arguments
      Make output diffable
      Fixed failure messages for file size matcher
      Restore behaviour of absolute_path
      Add spec only for special behaviour of absolute_path
      Make specs of exand_path look the same like all newer tests
      Use expand_path for the easier ones of File.expand_path
      Fixed spaces of curly brace
      Fixed expand_path for check_presence
      Fixed expand_path for check_file_size
      Fixed expand_path for with_file_content
      Fixed check_file_content
      Fixed check_directory_presence
      There's no need for prep_for_fs_check anymore. So let's deprecate it
      Use expand_path in cucumber steps as well
      Add path_content-method to read content of file or directory
      Use path_content for all_paths
      Check if directory has sub-directory
      Rubocop is a bit to picky with raised exceptions
      Fix use of absolute_path
      Update bundler in gemspec
      Disable raise args, I consider this a FalsePositive
      Use the copy-command to provide a fixture-step for cucumber
      Cleanup SpawnProcess a bit
      Replace in_current_dir with expand_path
      Namespace for processes
      Added legacy compatibility API
      Add support to append value to environment variable
      Add before/after hook for spawn process
      Move same methods to super class
      Add debug tag to switch command runner
      Add missing methods for in_process
      Refactor methods
      Exclude fixtures to prevent cucumber from loading ruby scripts
      Rename last_process to last_command
      Added matchers for command execution
      Refactored announcer
      Added process_monitor to refactor command execution
      Move code to utils module
      Removed duplicated code
      Workaround for missing announcer method

Jarl Friis (6):
      Merge pull request #225 from dg-ratiodata/feature/faster_builds_on_travis
      Merge pull request #229 from dg-ratiodata/feature/mtime
      Merge pull request #230 from hayamiz/fix-typo
      Merge pull request #226 from dg-ratiodata/feature/make_dir_look_like_file
      expand_path like File.expand_path, introducing FIXTURES_PATH_PREFIX as non-configurable, raising exception when using fixtures directory and it does not exists
      Closing #232, Closing #224

Luke Imhoff (1):
      Add simplecov to specs and cucumber features

Matt Wynne (13):
      Work around https://github.com/cucumber/cucumber/issues/827
      Update README.md
      Merge pull request #234 from dg-ratiodata/feature/file_does_not_exist
      Update History.md
      Merge pull request #239 from dg-ratiodata/feature/public_mode
      Update History.md
      Merge pull request #238 from dg-ratiodata/feature/have_content
      Update History.md
      Merge pull request #244 from dg-ratiodata/feature/rspec_integration
      Update History.md
      Merge pull request #243 from dg-ratiodata/feature/remove
      Update History.md
      Add Dennis to the list of contributors

Max Meyer (53):
      Added matcher for file size
      Add rspec integrator
      Errors should be available from api as well
      Replace remove_directory and remove_file through remove
      Replace touch_file through touch
      Added documentation to errors
      Split up rspec configuration
      Added helper scripts
      Basic support for simplecov
      Move development gems to Gemfile to make require easier in spec_helper
      Use bundle_args to prevent debug gems to be installed on travis
      Updated history
      Fixed rubocop offense
      Check on nil and empty in path
      Merge pull request #235 from smortex/patch-1
      Add gitter badge to readme
      Now create_directory uses the new style
      Merge branch 'feature/use_expand_path_everywhere'
      Merge pull request #217 from rapid7/feature/MSP-11399/simplecov
      Minor cleanup of simplecov merge
      Disable cucumber-pro for now, see cucumber-ltd/cucumber-pro-ruby#4
      Moved configuration of rubocop to a central place
      Upgrade rubocop
      Cleanup rubocop configuration
      Fixed offenses for Performance/ParallelAssignment
      Fixed offenses for Style/EmptyLinesAroundBlockBody
      Fixed offenses for Style/FormatString
      Fixed offenses for Style/EmptyLinesAroundModuleBody
      Fixed offenses for Style/BlockDelimiters
      Fixed offenses for Style/EmptyLinesAroundClassBody
      Split up method read
      Add check for absolute/relative
      Remove return it's not needed
      Added new helpers for files and directories in current dir
      Add matcher to check if path is absolute
      Add builder for directory object
      Fixed comments
      Merge pull request #250 from dg-ratiodata/feature/path_content
      Improved file content matcher. Closes #249
      Add copy method
      Fixed bug in documentation for be_existing_file
      Minor refactoring of shared context of aruba
      Improvements to existing file matchers
      Merge pull request #219 from dg-ratiodata/feature/copy_file
      Add documentation to spawn_process
      Improve specs for spawn_process
      Replace @@main_class through class instance variable
      Add console-script to use aruba directly
      Replace interactive through last_process
      Make it compatible with ruby 1.9
      Merge pull request #257 from dg-ratiodata/feature/use_current_working_directory_for_process
      Merge pull request #275 from DVG/update-vendored-jquery
      Version bump

Romain Tartière (1):
      Fix typo

Yuto Hayamizu (1):
      fix typo

-----------------------------------------------------------------------

No new revisions were added by this update.

-- 
Alioth's /usr/local/bin/git-commit-notice on /srv/git.debian.org/git/pkg-ruby-extras/ruby-aruba.git



More information about the Pkg-ruby-extras-commits mailing list