[DRE-maint] Bug#448175: libqt4-ruby1.8: "require 'Qt'" failures

Hans Grobler grobh at didima.net
Fri Oct 26 17:01:49 UTC 2007

Package: libqt4-ruby1.8
Version: 1.4.9-5
Severity: normal

- Installed the Ruby Qt binding the first time. Most aspects work correctly.
- All examples fail to work due to "require 'Qt'", which doesn't
  exist (only Qt3.rb and Qt4.rb are installed by the package).
- The installed "/usr/bin/rbqtapi" also fails for the same reason.

-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.22-2-686 (SMP w/4 CPU cores)
Locale: LANG=en_ZA.UTF-8, LC_CTYPE=en_ZA.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages libqt4-ruby1.8 depends on:
ii  libruby1.8           Libraries necessary to run Ruby 1.
ii  libsmokeqt4-1                 1.4.9-5    Smoke library for Qt4
ii  ruby                          1.8.2-1    An interpreter of object-oriented 
ii  ruby1.8              Interpreter of object-oriented scr

libqt4-ruby1.8 recommends no packages.

-- no debconf information

More information about the Pkg-ruby-extras-maintainers mailing list