[DRE-maint] Bug#478075: segfaults on startup

Vincent Fourmond fourmond at debian.org
Sat Apr 26 21:23:22 UTC 2008

Package: libqt4-ruby1.8
Version: 1.4.9-10
Severity: grave
Justification: package currently broken

  libqt4-ruby simply segfaults whenever one wants to load 'Qt4':

ruby test_checkarg.rb 
/usr/lib/ruby/1.8/Qt/qtruby4.rb:2091: [BUG] Segmentation fault
ruby 1.8.6 (2008-03-03) [x86_64-linux]

zsh: abort      ruby test_checkarg.rb


-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.24-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_GB, LC_CTYPE=en_GB (charmap=ISO-8859-1) (ignored: LC_ALL set to en_GB)
Shell: /bin/sh linked to /bin/dash

Versions of packages libqt4-ruby1.8 depends on:
ii  libc6                        2.7-10      GNU C Library: Shared libraries
ii  libgcc1                      1:4.3.0-3   GCC support library
ii  libqt4-dbus                  4.4.0~rc1-4 Qt 4 D-Bus module
ii  libqt4-gui                   4.4.0~rc1-4 Qt 4 GUI module
ii  libqt4-network               4.4.0~rc1-4 Qt 4 network module
ii  libqt4-opengl                4.4.0~rc1-4 Qt 4 OpenGL module
ii  libqt4-sql                   4.4.0~rc1-4 Qt 4 SQL module
ii  libqt4-svg                   4.4.0~rc1-4 Qt 4 SVG module
ii  libqt4-xml                   4.4.0~rc1-4 Qt 4 XML module
ii  libqtcore4                   4.4.0~rc1-4 Qt 4 core module
ii  libruby1.8          Libraries necessary to run Ruby 1.
ii  libsmokeqt4-1                1.4.9-10    Smoke library for Qt4
ii  libstdc++6                   4.3.0-3     The GNU Standard C++ Library v3
ii  ruby                         4.2         An interpreter of object-oriented 
ii  ruby1.8             Interpreter of object-oriented scr

libqt4-ruby1.8 recommends no packages.

-- no debconf information

More information about the Pkg-ruby-extras-maintainers mailing list