[DRE-maint] Bug#493299: rubygems1.9 uses wrong Gem path

Alexander Beisig abeisig at speech-design.de
Fri Aug 1 20:51:04 UTC 2008

Package: rubygems1.9
Version: 1.2.0-1
Severity: normal

When requiring rubygems1.9, it uses a wrong Gem path and consequently
fails to find any of the installed gems.

For Example:

$ ruby1.9 -rubygems -e 'puts Gem.path'

The correct Gem path on Debian should be /var/lib/gems/1.9.0 instead.

-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.25-2-686 (SMP w/2 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages rubygems1.9 depends on:
ii  rdoc1.9               Generate documentation from Ruby s
ii  ruby1.9               Interpreter of object-oriented scr

rubygems1.9 recommends no packages.

Versions of packages rubygems1.9 suggests:
ii  build-essential               11.4       Informational list of build-essent
ii  ruby1.9-dev           Header files for compiling extensi
pn  rubygems-doc                  <none>     (no description available)

-- no debconf information

More information about the Pkg-ruby-extras-maintainers mailing list