[DRE-maint] Bug#479502: libcommandline-ruby1.8 and open4.rb
daniel.leidert at wgdd.de
Thu May 8 14:52:13 UTC 2008
Esteban Manchado Velázquez wrote:
> I don't understand. The new libcommandline-ruby1.8 *doesn't* include
> open4.rb anymore, it *depends* on libopen4-ruby now:
That's one side of the problem, that you solved.
> If you just upgrade everything, you should get the new
> libcommandline-ruby1.8, which doesn't include open4.rb, and everything
> should work, right?
> Do you have the new libcommandline-ruby1.8 installed?
No I did not update it first, because it was hold back and I manually installed
libopen4-ruby1.8 first (to examine, which packages are hold back for Perl 5.10
transition). So I did run into the problem, because libopen4-ruby1.8 missed to
declare the open4.rb replacement accordingly to section 7.5(.1) of the Debian
Replaces: libcommandline-ruby1.8 (<< 0.7.10-10)
should solve this finally.
More information about the Pkg-ruby-extras-maintainers