[DRE-maint] Bug#522383: libgtk2-ruby1.8: rbgtkconversions.h is missing

Detlef Reichl detlef.reichl at gmx.org
Fri Apr 3 09:34:48 UTC 2009

Package: libgtk2-ruby1.8
Version: 0.18.1-1
Severity: normal

The file "rbgtkconversions.h" refered by /usr/lib/ruby/1.8/powerpc-linux/rbgtk.h is not included in the libgtk2-ruby1.8 package. So the build of ruby-gtk extensions will fail while compilation.

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: powerpc (ppc)

Kernel: Linux 2.6.26-1-powerpc
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages libgtk2-ruby1.8 depends on:
ii  libatk1-ruby1.8        0.18.1-1          ATK bindings for the Ruby language
ii  libatk1.0-0            1.22.0-1          The ATK accessibility toolkit
ii  libc6                  2.9-4             GNU C Library: Shared libraries
ii  libcairo2              1.8.6-2+b1        The Cairo 2D vector graphics libra
ii  libfontconfig1         2.6.0-3           generic font configuration library
ii  libfreetype6           2.3.9-4           FreeType 2 font engine, shared lib
ii  libgdk-pixbuf2-ruby1.8 0.18.1-1          Gdk-Pixbuf 2 bindings for the Ruby
ii  libglib2.0-0           2.20.0-2          The GLib library of C routines
ii  libgtk2.0-0            2.14.7-5          The GTK+ graphical user interface 
ii  libpango1-ruby1.8      0.18.1-1          Pango bindings for the Ruby langua
ii  libpango1.0-0          1.22.4-2          Layout and rendering of internatio
ii  libruby1.8           Libraries necessary to run Ruby 1.
ii  zlib1g                 1: compression library - runtime

libgtk2-ruby1.8 recommends no packages.

libgtk2-ruby1.8 suggests no packages.

-- no debconf information

More information about the Pkg-ruby-extras-maintainers mailing list