[DRE-maint] Bug#517817: Bug#517817: rubygems1.9 is not compatible with ruby1.9(

Lucas Nussbaum lucas at lucas-nussbaum.net
Mon Mar 2 10:35:53 UTC 2009

On 02/03/09 at 18:04 +0800, slepher wrote:
> package: rubygems1.9
> Version: 1.3.1-1
> rubygems install on /usr/lib/ruby/1.9.0 while ruby1.9.1 use 
> /usr/lib/ruby/1.9.1 as it's lib path

ruby1.9.1 was uploaded to experimental for a reason.

All libraries currently in debian _unstable_ are incompatible with ruby
1.9.1 because of the above problem. We need to work on a transition
plan, and possibly changes that allow us not to re-do the same
transition with ruby 1.9.2.

Apparently, the best thing to do is a symlink farm like python-support.
But it takes some time to implement correctly, and I don't have any,
currently, so it will likely be someone else's task.
| Lucas Nussbaum
| lucas at lucas-nussbaum.net   http://www.lucas-nussbaum.net/ |
| jabber: lucas at nussbaum.fr             GPG: 1024D/023B3F4F |

More information about the Pkg-ruby-extras-maintainers mailing list