[DRE-maint] Bug#553667: [libparsetree-ruby] Requires rubygems

Tobias Grimm tobias.grimm at e-tobi.net
Sun Nov 1 20:09:22 UTC 2009

Package: libparsetree-ruby
Version: 3.0.4-1
Severity: normal
Tags: patch

--- Please enter the report below this line. ---

When preparing an upload of rspec 1.2.9, I saw, that libparsetree-ruby
requires rubygems. Besides this upstream had a bug in his
begin/require/rescue/end block usage.

Also reported upstream:


Please see the attached patch.	

--- System information. ---
Architecture: amd64
Kernel:       Linux 2.6.30-1-amd64

Debian Release: squeeze/sid
  500 testing         www.debian-multimedia.org 
  500 testing         security.debian.org 
  500 testing         ftp.de.debian.org 
 1001 unstable        ftp.debian.org 

--- Package information. ---
Depends                   (Version) | Installed
libparsetree-ruby1.8                | 2.2.1-2

Package's Recommends field is empty.

Package's Suggests field is empty.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: 30_no-rubygems.dpatch
Type: application/x-shellscript
Size: 2624 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/pkg-ruby-extras-maintainers/attachments/20091101/828cd72b/attachment.bin>

More information about the Pkg-ruby-extras-maintainers mailing list