[DRE-maint] Bug#576113: rubygems: IPv6 HTTP Proxy doesn't work

Witold Baryluk baryluk at smp.if.uj.edu.pl
Thu Apr 1 01:22:40 UTC 2010

Package: rubygems
Version: 1.3.5-2
Severity: important
Tags: ipv6

$ netstat -apn | grep 8118 | grep LISTEN tcp6       0      0 ::1:8118
:::*                    LISTEN      -               5123/privoxy $ grep local
/etc/hosts       localhost ::1     localhost ip6-localhost
ip6-loopback $ env | grep proxy http_proxy=http://localhost:8118
no_proxy=localhost, $ gem install --remote sprockets ERROR:
http://gems.rubyforge.org/ does not appear to be a repository ERROR:  could not
find gem sprockets locally or in a repository $ export http_proxy= $ gem
install --remote sprockets WARNING:  Installing to ~/.gem since
/var/lib/gems/1.8 and           /var/lib/gems/1.8/bin aren't both writable.
WARNING:  You don't have /home/baryluk/.gem/ruby/1.8/bin in your PATH,
gem executables will not run. Successfully installed sprockets-1.0.2 1 gem
installed Installing ri documentation for sprockets-1.0.2... Installing RDoc
documentation for sprockets-1.0.2... $   It is probably not directly releated
to bug in rubygems, but i don't have enought expertise in Ruby to find which
module in Ruby is handling HTTP proxy.  If so please reassign this bug to
proper package.  Thanks You.

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.34-rc2-sredniczarny-00184-g01e7770 (PREEMPT)
Locale: LANG=pl_PL.UTF-8, LC_CTYPE=pl_PL.UTF-8 (charmap=UTF-8) (ignored: LC_ALL set to pl_PL.UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages rubygems depends on:
ii  rubygems1.8                   1.3.5-2    package management framework for R

rubygems recommends no packages.

rubygems suggests no packages.

-- no debconf information

More information about the Pkg-ruby-extras-maintainers mailing list