[DRE-maint] RFS: libglobalhotkeys-ruby

Lucas Nussbaum lucas at lucas-nussbaum.net
Wed Aug 4 01:58:47 UTC 2010

On 03/08/10 at 17:53 +0200, vincent carmona wrote:
> Hi team.
> I have uploaded libglobalhotkeys-ruby in the svn repository.


Quick review:
- use english for commit messages :-)
- changelog: UNRELEASED -> unstable
- you should have a libglobalhotkeys-ruby1.8 that contains the actual
  files, as well as a libglobalhotkeys-ruby package that simply depends
  on libglobalhotkeys-ruby (see the other packages in the repo)
- no '.' at end of Description's first line.
- use sentences in long description.
- in rules, use the cdbs classes provided by the team, not the default
  debhelper template (see other packages)
- your library is loaded using require 'rghk', so I think that it makes
  more sense to name the package librghk-ruby.
> I still have two lintian infos :
> description-synopsis-might-not-be-phrased-properly
> possible-documentation-but-no-doc-base-registration
> Do you think I should rephrase the description or use doc-base ?

Yes, probably both.
| Lucas Nussbaum
| lucas at lucas-nussbaum.net   http://www.lucas-nussbaum.net/ |
| jabber: lucas at nussbaum.fr             GPG: 1024D/023B3F4F |

More information about the Pkg-ruby-extras-maintainers mailing list