[DRE-maint] questions on package release

Lucas Nussbaum lucas at lucas-nussbaum.net
Tue Jan 19 02:55:12 UTC 2010

On 19/01/10 at 11:11 +0900, Daiki Ueno wrote:
> Hi,
> I'm now trying to make a new release of the libusb-ruby package, to fix
> Bug#565834, following the instructions on the website.
> I have a few questions:
> * The page "Using Subversion" links to "Upstream Sources" where
>   pkg-ruby-get-sources is still mentioned.  How about the attached
>   change to website, to remove the reference?

Looks good, please commit and update the website.

> * Since I'm not yet a DM, I can't upload the new package by myself - so
>   I'm now stopping at 6. of the checklist (actually I have committed the
>   change to the trunk).  Is my understanding correct that someone will
>   upload it if I make a tag for the release?

No, you need to explicitely ask, as you just did :-)

But I see that your change was to support 1.9.1. I have now updated the
wiki with more information about that transition, and it seems you miss
the build-dep on ruby-pkg-tools >= 0.17.
| Lucas Nussbaum
| lucas at lucas-nussbaum.net   http://www.lucas-nussbaum.net/ |
| jabber: lucas at nussbaum.fr             GPG: 1024D/023B3F4F |

More information about the Pkg-ruby-extras-maintainers mailing list