[DRE-maint] Bug#639398: ruby-gtk2: liststore broken in Debian build

Michal Suchanek michal.suchanek at ruk.cuni.cz
Fri Aug 26 20:27:47 UTC 2011

Package: ruby-gtk2
Version: 1.0.0-1
Severity: normal

Was debugging a demo with a liststore an found that liststores don't
work in the Debian package but do work in in perfectly when the package
is removed and gem installed.

Attaching the demo which fails.

-- System Information:
Debian Release: wheezy/sid
  APT prefers stable
  APT policy: (900, 'stable'), (500, 'testing'), (410, 'unstable'), (200, 'experimental'), (111, 'oldstable'), (107, 'natty-updates'), (107, 'natty')
Architecture: amd64 (x86_64)

Kernel: Linux 3.0.0-rc3-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8) (ignored: LC_ALL set to en_US.UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages ruby-gtk2 depends on:
ii  libatk1.0-0           2.0.1-2            ATK accessibility toolkit
ii  libc6                 2.13-10            Embedded GNU C Library: Shared lib
ii  libcairo2             1.10.2-6.1         The Cairo 2D vector graphics libra
ii  libfontconfig1        2.8.0-2.1          generic font configuration library
ii  libfreetype6          2.4.2-2.1+squeeze1 FreeType 2 font engine, shared lib
ii  libgdk-pixbuf2.0-0    2.23.5-3           GDK Pixbuf library
ii  libglib2.0-0          2.28.6-1           The GLib library of C routines
ii  libgtk2.0-0           2.24.5-4cmb1       GTK+ graphical user interface libr
ii  libpango1.0-0         1.28.4-1           Layout and rendering of internatio
ii  libruby1.8          Libraries necessary to run Ruby 1.
ii  libruby1.9.1        Libraries necessary to run Ruby 1.
ii  libx11-6              2:1.3.3-4          X11 client-side library
ii  ruby-atk              1.0.0-1            ATK bindings for the Ruby language
ii  ruby-gdk-pixbuf2      1.0.0-1            Gdk-Pixbuf 2 bindings for the Ruby
ii  ruby-pango            1.0.0-1            Pango bindings for the Ruby langua

ruby-gtk2 recommends no packages.

ruby-gtk2 suggests no packages.

-- no debconf information
-------------- next part --------------
A non-text attachment was scrubbed...
Name: twin_tree_view.rb
Type: text/x-ruby
Size: 3808 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/pkg-ruby-extras-maintainers/attachments/20110826/39aca465/attachment-0003.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: twin_tree_view.glade
Type: application/xml
Size: 9947 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/pkg-ruby-extras-maintainers/attachments/20110826/39aca465/attachment-0003.wsdl>

More information about the Pkg-ruby-extras-maintainers mailing list