[DRE-maint] How to run several rake builds in the same package

ludovic.claude at laposte.net ludovic.claude at laposte.net
Mon Jun 13 18:34:37 UTC 2011


I'm new to Ruby, but not Debian packaging - I've been doing lots of Java packaging.

I would like to update one package which I'm using (libcompass-ruby), and for that I need also to update libhaml-ruby to a newer version - 3.1.2.
My problem with that package is that the upstream code structure has changed, and now the Sass gem has moved to its own directory (vendor/sass) with its own Rakefile.

debian/rules uses ruby-setup-rb.mk and launches the build for the Rakefile located at the root, but it doesn't launch vendor/sass/Rakefile. How can I do that?

I have started some work here:

Thanks for your help,

Une messagerie gratuite, garantie à vie et des services en plus, ça vous tente ?
Je crée ma boîte mail www.laposte.net

More information about the Pkg-ruby-extras-maintainers mailing list