[DRE-maint] Bug#642382: redmine: >= 1.2 must depend on Rails >= 2.3.11~ and maybe TMail >= 1.2.7~

Arnaud Fontaine arnau at debian.org
Thu Sep 22 09:04:29 UTC 2011

Jérémy Lal <jerry at edagames.com> writes:

> Thank you for your bug report,  could you explain the meaning of tilda
> ~ in  versions dependencies ?  I  can't find an  explanation in debian
> docs.

It's  useful to  allow dependencies  to be  satisfied  with pre-released
versions[0] (such as RC) and also to allow using backported packages for
rails  (as  backport  version  is something  like  2.3.11-1~bpo60+1  for

You can easily check with dpkg --compare-versions:

$ dpkg --compare-versions '2.3.11-1' '>' '2.3.11-1~bpo60+1' && echo true || echo false

BTW, after checking TMail, it does not seem necessary to explicitely add
it as ruby-rails-2.3  (2.3.14-2 but I dunno for  older versions) depends
upon  ruby-actionmailer-2.3  which  in  turn depends  on  ruby-tmail  >=
1.2.7~, but  it's up  to you of  course as  I don't know  anything about
Rails ;).

Arnaud Fontaine

[0] http://www.debian.org/doc/debian-policy/footnotes.html#f37
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/pkg-ruby-extras-maintainers/attachments/20110922/2306159f/attachment.pgp>

More information about the Pkg-ruby-extras-maintainers mailing list