[DRE-maint] [Bug 831170] Re: libdb-ruby version 0.6.5-6 failed to build in oneiric

Launchpad Bug Tracker 831170 at bugs.launchpad.net
Thu Sep 22 18:28:52 UTC 2011

This bug was fixed in the package libdb-ruby - 0.6.5-6ubuntu1

libdb-ruby (0.6.5-6ubuntu1) oneiric; urgency=low

  * Build-depend on libdb4.8-dev. Tests fail with DB 5.x. LP: #831170.
 -- Matthias Klose <doko at ubuntu.com>   Thu, 22 Sep 2011 20:04:06 +0200

** Changed in: libdb-ruby (Ubuntu Oneiric)
       Status: Confirmed => Fix Released

You received this bug notification because you are subscribed to Ubuntu.

  libdb-ruby version 0.6.5-6 failed to build in oneiric

Status in “libdb-ruby” package in Ubuntu:
  Fix Released
Status in “libdb-ruby” source package in Oneiric:
  Fix Released

Bug description:
  libdb-ruby version 0.6.5-6 failed to build in oneiric
  Link to failed build: https://launchpad.net/ubuntu/+archive/test-rebuild-20110816/+build/2700099

  Details about the rebuild:

  Direct link to the build log: https://launchpad.net/ubuntu/+archive

  This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
  Excerpt 1045 lines into the build log:

  mkdir -p /build/buildd/libdb-ruby-0.6.5/debian/libdb-ruby1.8/usr/lib/ruby/1.8/x86_64-linux
  /usr/bin/install -c -m 0755 bdb.so /build/buildd/libdb-ruby-0.6.5/debian/libdb-ruby1.8/usr/lib/ruby/1.8/x86_64-linux
  make[2]: Leaving directory `/build/buildd/libdb-ruby-0.6.5/src'
  make[1]: Leaving directory `/build/buildd/libdb-ruby-0.6.5'
  make test
  make[1]: Entering directory `/build/buildd/libdb-ruby-0.6.5'
  ruby1.8 tests/recnum.rb
  src/bdb.so:  (NotImplementedError)
  BDB needs compatible versions of libdb & db.h
  	you have db.h version 5.1.25 and libdb version 4.8.30
  	from tests/recnum.rb:3
  make[1]: *** [test] Error 1
  make[1]: Leaving directory `/build/buildd/libdb-ruby-0.6.5'
  make: *** [install/libdb-ruby1.8] Error 2
  dpkg-buildpackage: error: /usr/bin/fakeroot debian/rules binary-arch gave error exit status 2
  Build finished at 20110821-1700
  FAILED [dpkg-buildpackage died]
  Purging chroot-autobuild/build/buildd/libdb-ruby-0.6.5

To manage notifications about this bug go to:

More information about the Pkg-ruby-extras-maintainers mailing list