[Pkg-samba-maint] Bug#433449: samba: nmbd shuts down when network interfaces go down

Sam Morris sam at robots.org.uk
Tue Jul 17 09:12:48 UTC 2007

Package: samba
Version: 3.0.24-6
Severity: important

Hash: SHA1

My system's network connection is a wireless one, and whenever I bring
the interface down to change networks, or get the hardware's driver back
into an unconfused state (it's not the most stable piece of coding),
nmbd exits.

[2007/07/17 09:00:19, 0] nmbd/nmbd.c:reload_interfaces(229)
  reload_interfaces: No subnets to listen to. Shutting down...

It should just hang around, listening on localhost and/or (all
interfaces) until another network interface comes back up. Currently, I
have to start it manually whenever it shuts down.

- -- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (530, 'testing'), (520, 'unstable'), (510, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.21-2-k7 (SMP w/1 CPU core)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages samba depends on:
ii  debconf  1.5.13                          Debian configuration management sy
ii  libacl1  2.2.42-1                        Access control list shared library
ii  libattr1 1:2.4.32-1.1                    Extended attribute shared library
ii  libc6    2.6-2                           GNU C Library: Shared libraries
ii  libcomer 1.39+1.40-WIP-2006.11.14+dfsg-2 common error description library
ii  libcupsy 1.2.11-3                        Common UNIX Printing System(tm) - 
ii  libgnutl 1.6.3-1                         the GNU TLS library - runtime libr
ii  libkrb53 1.6.dfsg.1-5                    MIT Kerberos runtime libraries
ii  libldap2 2.1.30-13.4                     OpenLDAP libraries
ii  libpam-m 0.79-4                          Pluggable Authentication Modules f
ii  libpam-r 0.79-4                          Runtime support for the PAM librar
ii  libpam0g 0.79-4                          Pluggable Authentication Modules l
ii  libpopt0 1.10-3                          lib for parsing cmdline parameters
ii  logrotat 3.7.1-3                         Log rotation utility
ii  lsb-base 3.1-23.1                        Linux Standard Base 3.1 init scrip
ii  procps   1:3.2.7-3                       /proc file system utilities
ii  samba-co 3.0.25b-1+b1                    Samba common files used by both th
ii  update-i 4.27-0.5                        inetd.conf updater
ii  zlib1g   1:                compression library - runtime

Versions of packages samba recommends:
pn  smbldap-tools                 <none>     (no description available)

- -- debconf information:
  samba/tdbsam: false
* samba/generate_smbpasswd: false
* samba/run_mode: daemons

Version: GnuPG v1.4.6 (GNU/Linux)


More information about the Pkg-samba-maint mailing list