[Pkg-samba-maint] Bug#427986: samba: not permitted access to share IPC$

Gordon Haverland ghaverla at materialisations.com
Thu Jun 7 20:08:00 UTC 2007

Package: samba
Version: 3.0.25a-1
Severity: normal

It has been ages since I did anything with samba, so mostly a
newbie.  I was trying to set things up for user security, however
that might be attained, and testing things from a Windows-XP box
(XP Home I believe).

I had attempted to write a complete smb.conf from the beginning,
instead of making incremental changes to something minimal.  And
almost everything I tried resulted in this IPC$ problem.

I then tried building something in small steps from almost nothing.
When I added a "valid users = ..." line, I started getting the
IPC$ message again (and logons/browsing failing).  Usernames in
lowercase, in uppercase, or repetitions of a lowercase and an
uppercase name were all tried.  They all cause the same problem.

In searching for answers, I ran across lots of bug reports where
this seems to be a symptom, but hadn't run across solutions.  So,
there are probably a few different things which create this IPC$
symptom.  I can work with the setup I eventually created, so I
don't need a resolution to this.

I was adding this to the [globals] section, which in afterthought
was probably a mistake.  If so, perhaps this is something that testparm
can look for?

I tried sending this once before, and then realised exim4 wasn't
properly configured.  Hopefully this other copy won't resurface.

-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.21 (SMP w/2 CPU cores)
Locale: LANG=en_CA.UTF-8, LC_CTYPE=en_CA.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages samba depends on:
ii  debconf  1.5.13                          Debian configuration management sy
ii  libacl1  2.2.42-1                        Access control list shared library
ii  libattr1 1:2.4.32-1.1                    Extended attribute shared library
ii  libc6    2.5-9+b1                        GNU C Library: Shared libraries
ii  libcomer 1.39+1.40-WIP-2007.04.07+dfsg-2 common error description library
ii  libcupsy 1.2.11-2                        Common UNIX Printing System(tm) - 
ii  libgnutl 1.6.3-1                         the GNU TLS library - runtime libr
ii  libkrb53 1.6.dfsg.1-4                    MIT Kerberos runtime libraries
ii  libldap2 2.1.30-13.4                     OpenLDAP libraries
ii  libpam-m 0.79-4                          Pluggable Authentication Modules f
ii  libpam-r 0.79-4                          Runtime support for the PAM librar
ii  libpam0g 0.79-4                          Pluggable Authentication Modules l
ii  libpopt0 1.10-3                          lib for parsing cmdline parameters
ii  logrotat 3.7.1-3                         Log rotation utility
ii  lsb-base 3.1-23.1                        Linux Standard Base 3.1 init scrip
ii  procps   1:3.2.7-3                       /proc file system utilities
ii  samba-co 3.0.25a-1                       Samba common files used by both th
ii  update-i 4.27-0.5                        inetd.conf updater
ii  zlib1g   1:1.2.3-15                      compression library - runtime

Versions of packages samba recommends:
ii  smbldap-tools                 0.9.2-3    Scripts to manage Unix and Samba a

-- debconf information:
  samba/tdbsam: false
* samba/generate_smbpasswd: true
* samba/run_mode: daemons

More information about the Pkg-samba-maint mailing list