[Pkg-samba-maint] Bug#427986: Bug#427986: samba: not permitted access to share IPC$

Christian Perrier bubulle at debian.org
Fri Jun 8 05:28:05 UTC 2007

Quoting Gordon Haverland (ghaverla at materialisations.com):
> Package: samba
> Version: 3.0.25a-1
> Severity: normal
> It has been ages since I did anything with samba, so mostly a
> newbie.  I was trying to set things up for user security, however
> that might be attained, and testing things from a Windows-XP box
> (XP Home I believe).
> I had attempted to write a complete smb.conf from the beginning,
> instead of making incremental changes to something minimal.  And
> almost everything I tried resulted in this IPC$ problem.
> I then tried building something in small steps from almost nothing.
> When I added a "valid users = ..." line, I started getting the
> IPC$ message again (and logons/browsing failing).  Usernames in
> lowercase, in uppercase, or repetitions of a lowercase and an
> uppercase name were all tried.  They all cause the same problem.
> In searching for answers, I ran across lots of bug reports where
> this seems to be a symptom, but hadn't run across solutions.  So,
> there are probably a few different things which create this IPC$
> symptom.  I can work with the setup I eventually created, so I
> don't need a resolution to this.
> I was adding this to the [globals] section, which in afterthought
> was probably a mistake.  If so, perhaps this is something that testparm
> can look for?
> I tried sending this once before, and then realised exim4 wasn't
> properly configured.  Hopefully this other copy won't resurface.

Well, part from the above explanations, could you post your smb.conf,
explain exactly what problem is happening and eventually post level 3
logs (at first attempt....).

Up to now, we're mostly in the dark to understand what your problem
might be.

I seem to understand you're using "valid users" in the [globals]
section. If you do so, don't be surprised to get unexpected
results. "valid users" is a "share" parameters as explained in the
smb.conf manpage (funnily, it seems to work slightly but that may be
mor ea kind of side effect than anything really intended).

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : http://lists.alioth.debian.org/pipermail/pkg-samba-maint/attachments/20070608/4e294ed4/attachment.pgp 

More information about the Pkg-samba-maint mailing list