[Pkg-samba-maint] Problems with autoconf.patch and 3.2.0pre1

Steve Langasek vorlon at debian.org
Mon Oct 1 17:54:33 UTC 2007

On Mon, Oct 01, 2007 at 09:51:22AM +0200, Christian Perrier wrote:
> Quoting Steve Langasek (vorlon at debian.org):

> > This looks to me like a misconfigured build environment.  What version of

> Yeah. I now nearly never use my laptop for building the package and it
> appears that autoconf2.13 is missing.

> Thanks for the hint.

Er -- you should *not* have autoconf2.13 installed, that package is obsolete
and doesn't work the same as recent versions of autoconf.  I meant that
having autoconf2.13 installed could be a *cause* of the problem, not a fix
for it.

Anyway, I've just had a chance to test myself and it's not an autoconf
installation problem - I get the same error here, on a system that I know
has a good autoconf install (tested against samba 3.0.26, even).

I'm still not sure what causes the error, but it turns out that using the
autoconf command from autogen.sh works just fine:

   autoconf -I m4 -I lib/replace

So please use that, and update the documentation in the patch to do the same
(the added include shouldn't hurt 3.0 builds, regardless).

Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
vorlon at debian.org                                   http://www.debian.org/

More information about the Pkg-samba-maint mailing list