[Pkg-samba-maint] Bug#561716: Bug#561716: samba: security=domain broken, server get's empty user name

Dr. Jürgen Pfennig info at j-pfennig.de
Sun Dec 27 13:01:39 UTC 2009

Hello and thanks for also making the 64bit version of 3.4.3 installable.
Here are some of my results:

1) There is a new regression with member servers and passwd expiry. The trust 
relationship (net join) only lasts for an hour. For one hour member server 
authentication works (with another regression, see point 2) and after that 
period it fails. The relevant information is not stored in LDAP - tweaking 
entries there does not help.

2) while smbclient automatically causes the smb member server to send the 
domain name, this is not true any longer for cifs mounts. In other words: 
smbclient works and mount.cifs fails - the member server only sends the user 
name to the master and leaves the domain empty. It is possible to add 
domain=xxxx to the mount options as a work around.

3) Somehow network browsing now breaks lenny's kde 3.5.10 konqueror. I can see 
the following console message: Could not get name of local/domain master 
browser for server XXX. This must be client side, with Ubuntu 9/10 and Samba 
3.4.0 browsing works. smbtree also works (lenny and ubuntu).

4) Ubuntu 9/10 with Samba 3.4.0 also does not work as a member server.

5) My windows 7 logon problem (samba server reports timeouts and only after 
30s windows and samba find a protocol that both sides can handle) has no been 
solved with 3.4.3

My setup:
- server is lenny+bpo udates, amd64.
- clients mostly lenny+bpo updates, amd64 and i386
- one client runs ubuntu 9/10 with samba 3.4.0
- server and clients (as needed) use open-ldap for authentication

So long, Jürgen

More information about the Pkg-samba-maint mailing list