[Pkg-samba-maint] Bug#601551: samba: Samba 3.5.6 (Squeeze) : Issues with Windows drivers settings

Greg Auz gregory.auzanneau at ketterthill.lu
Wed Oct 27 08:38:42 UTC 2010

Package: samba
Version: 2:3.5.6~dfsg-1
Severity: important
Tags: upstream

Since samba 3.4 there is an issue with driver settings :
- Opening setting on a driver take several seconds (annoying but not useless).
  This seems slow down the beginning of the printing.
- The more anoying part is that samba don't keep default settings set by sysadmin (Tray, Duplex, etc etc).
  We use a samba as a print server. We use A4 paper, but drivers will always request a Letter paper size because we can't change save default settings.
  Now user need, on every prints, to change their settings...

This issue is already known by samba team (https://bugzilla.samba.org/show_bug.cgi?id=6727).

Thank you all for the good work with samba, keep up with it ! :)


-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/4 CPU cores)
Locale: LANG=fr_LU.UTF-8, LC_CTYPE=fr_LU.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages samba depends on:
ii  adduser                 3.112            add and remove users and groups
ii  debconf [debconf-2.0]   1.5.36           Debian configuration management sy
ii  libacl1                 2.2.49-4         Access control list shared library
ii  libattr1                1:2.4.44-2       Extended attribute shared library
ii  libc6                   2.11.2-6         Embedded GNU C Library: Shared lib
ii  libcap2                 1:2.19-3         support for getting/setting POSIX.
ii  libcomerr2              1.41.12-2        common error description library
ii  libcups2                1.4.4-3          Common UNIX Printing System(tm) - 
ii  libgssapi-krb5-2        1.8.3+dfsg-2     MIT Kerberos runtime libraries - k
ii  libk5crypto3            1.8.3+dfsg-2     MIT Kerberos runtime libraries - C
ii  libkrb5-3               1.8.3+dfsg-2     MIT Kerberos runtime libraries
ii  libldap-2.4-2           2.4.23-6         OpenLDAP libraries
ii  libpam-modules          1.1.1-6          Pluggable Authentication Modules f
ii  libpam-runtime          1.1.1-6          Runtime support for the PAM librar
ii  libpam0g                1.1.1-6          Pluggable Authentication Modules l
ii  libpopt0                1.16-1           lib for parsing cmdline parameters
ii  libtalloc2              2.0.1-1          hierarchical pool based memory all
ii  libwbclient0            2:3.5.6~dfsg-1   Samba winbind client library
ii  lsb-base                3.2-23.1         Linux Standard Base 3.2 init scrip
ii  procps                  1:3.2.8-9        /proc file system utilities
ii  samba-common            2:3.5.6~dfsg-1   common files used by both the Samb
ii  update-inetd            4.37             inetd configuration file updater
ii  zlib1g                  1: compression library - runtime

Versions of packages samba recommends:
ii  logrotate                     3.7.8-6    Log rotation utility

Versions of packages samba suggests:
pn  ctdb                        <none>       (no description available)
pn  ldb-tools                   <none>       (no description available)
ii  openbsd-inetd [inet-superse 0.20080125-6 The OpenBSD Internet Superserver
pn  smbldap-tools               <none>       (no description available)

-- debconf information:
  samba/run_mode: daemons
  samba/generate_smbpasswd: true

More information about the Pkg-samba-maint mailing list