[Pkg-samba-maint] Bug#657314: Bug#657314: Bug#657314: Bug#657314: unstable: 2:3.6.1-3 fails to build due to incorrect python-ldb bindings

John David Anglin dave.anglin at bell.net
Fri Jan 27 19:20:02 UTC 2012

On 1/27/2012 1:54 PM, Steve Langasek wrote:
> On Fri, Jan 27, 2012 at 07:21:26PM +0100, Christian PERRIER wrote:
>> Quoting John David Anglin (dave.anglin at bell.net):
>>> On 26-Jan-12, at 9:22 AM, Jelmer Vernooij wrote:
>>>> ldb is also included in the Samba source tree, so a dependency isn't
>>>> necessary. Can you reproduce this *without* any ldb libraries
>>>> installed?
>>> I finally had a successful build.  In addition to removing the ldb
>>> libraries,
>>> I had to remove the python-talloc packages.  I think the problem is the
>> I'm tempted to close this bug as this is not really related to the
>> Debian package (that currently builds fine).
> If the package fails to build due to other unrelated packages being
> installed in the build environment, that's still a bug, just a
> lower-priority one.
I would guess that there is a problem with include paths.  The build 
should be picking
up its header files, and not the system headers.  From what I could see 
on the net,
there have been incompatible changes in the python bindings for both the 
ldb and talloc
source packages in recent versions.

Possibly the simplest solution is to just add the conflicts.

It shouldn't be necessary to manually supply the missing rfc's.


John David Anglin    dave.anglin at bell.net

More information about the Pkg-samba-maint mailing list