[Pkg-scicomp-devel] Bug#525023: libcv-dev: circular dependency with libcvaux-dev and libhighgui-dev

Bill Allombert ballombe at debian.org
Tue Apr 21 15:28:06 UTC 2009

Package: libcv-dev
Version: 1.0.0-6.1+b1
Severity: important

Hello Debian Scientific Computing Team,

There is a circular dependency between libcv-dev, libcvaux-dev and libhighgui-dev:

libcv-dev 	:Depends: libcvaux-dev (= 1.0.0-6.1+b1), libhighgui-dev (= 1.0.0-6.1+b1)
libcvaux-dev 	:Depends: libcv-dev (>= 1.0.0-6.1+b1)
libhighgui-dev 	:Depends: libcv-dev (>= 1.0.0-6.1+b1)

Circular dependencies are known to cause problems during upgrade, so we
should try to get rid of them.

In this particular case I do not see the point to have three separated 
packages if users are required to install them all anyway. A single
package would be sufficient. 

See threads 

Bill. <ballombe at debian.org>

Imagine a large red swirl here. 

More information about the Pkg-scicomp-devel mailing list