[Pkg-scicomp-devel] Bug#528522: libsuitesparse-3.2.0: Please link umfpack library with -lamd

Rafael Laboissiere rafael at debian.org
Wed May 13 13:06:39 UTC 2009

package libsuitesparse-3.2.0
severity 528522 serious
merge 528522 526422

* Adam C Powell IV <hazelsct at debian.org> [2009-05-13 08:39]:

> Package: libsuitesparse-3.2.0
> Version: 3.2.0-4
> Severity: minor
> Please link the umfpack shared library with amd, so one can just link
> -lumfpack when only using its symbols (instead of -lumfpack -lamd as is
> needed now).

This has been already reported as Bug#526422 and the fix is already in
Git [1].  I am hereby merging the bug reports accordingly.

[1] http://git.debian.org/?p=pkg-scicomp/suitesparse.git;a=blobdiff;f=debian/patches/11-UMFPACK_Lib_GNUmakefile.dpatch;h=e126d2fb02b3a78c9ed29a6a83dd4c46867412aa;hp=e0fe49fe64b79367d076f4f97e835d3646df063f;hb=71c479758afda826929080499e51f0c8bb3a4868;hpb=edeb4b1f5c28feacc61645d563700b94a619314b


More information about the Pkg-scicomp-devel mailing list