purge conflict between libapache2-mod-shib(2)

Ferenc Wagner wferi at niif.hu
Tue Nov 18 18:53:34 UTC 2008

Russ Allbery <rra at debian.org> writes:

> Ferenc Wagner <wferi at niif.hu> writes:
>> After upgrading libapache2-mod-shib2 to the newest version, I wanted
>> to finally purge libapache2-mod-shib, but that didn't work, as its
>> postrm invokes update-rc.d shibd remove, which reports an error as
>> /etc/init.d/shibd is still present.
>> Should we do something with this?
> Hm, yes, probably.  dpkg's handling of packages with conflicting
> configuration files really leaves a lot to be desired.
> That code is from debhelper.  I'm not sure what the best solution is.  I
> suppose we could override what debhelper is doing and put its code
> directly into libapache2-mod-shib's maintainer scripts, but that's
> somewhat unsatisfying.

Or rename the v2 init script to /etc/init.d/shibd2.  But that is a
very user-visible change.  Amusingly, we've already got a query why we
changed the init script name in the v2 package. :)  It took some time
to convince myself that we did not.

More information about the Pkg-shibboleth-devel mailing list