SP 2.0: Metadata with EncryptionMethod elements fails to load

Russ Allbery rra at debian.org
Tue Jan 20 18:46:08 UTC 2009

"Scott Cantor" <cantor.2 at osu.edu> writes:

> The schemas that could change (i.e. not the SAML ones) are backward
> compatible, but not forward. A valid configuration on 2.0 is guaranteed
> to validate against the 2.1 schema but not vice versa. So, yes, if
> you're packaging the schemas separately from the SP itself, you need to
> make sure that a 2.1 SP is using at least the 2.1 schemas.

Okay, thanks.  I'm adding a versioned dependency on the 2.1 SP schemas to
the SP library package.  I'm assuming from what you said above that making
sure the 2.1 OpenSAML library has the 2.1 schemas isn't required.

Are there versioning constraints for the XMLTooling-C schemas?  Does a 2.1
SP require at least the 1.1 schemas, for example, or the 1.1 library
require the 1.1 schemas?

Russ Allbery (rra at debian.org)               <http://www.eyrie.org/~eagle/>

More information about the Pkg-shibboleth-devel mailing list