[Pkg-sysvinit-devel] Bug#601873: /usr/sbin/update-rc.d: Required-start is not applied

rpnpif rpnpif at free.fr
Sat Oct 30 13:57:12 UTC 2010

Package: sysv-rc
Version: 2.88dsf-12
Severity: important
File: /usr/sbin/update-rc.d

We have :
# Provides:          postfix mail-transport-agent

# Required-Start:    $network $local_fs $remote_fs $syslog $mail-transport-agent

but fetchmail starts before postfix.
In /etc/init.d/.depend.start fetchmail is also before postfix.

Only a "Required-Start: postfix" will make postfix to start before fetchmail.

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-5-686 (SMP w/1 CPU core)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages sysv-rc depends on:
ii  debconf [debconf-2.0]         1.5.36     Debian configuration management sy
ii  insserv                       1.14.0-2   Tool to organize boot sequence usi
ii  sysvinit-utils                2.88dsf-12 System-V-like utilities

Versions of packages sysv-rc recommends:
ii  lsb-base                      3.2-23.1   Linux Standard Base 3.2 init scrip

Versions of packages sysv-rc suggests:
pn  bum                           <none>     (no description available)
pn  sysv-rc-conf                  <none>     (no description available)

-- debconf information:
* sysv-rc/unable-to-convert:
* sysv-rc/convert-legacy: true

More information about the Pkg-sysvinit-devel mailing list