[Pkg-uml-devel] Re: [uml-devel] "Configuring network interfaces...execvp of 'uml_net' failed - errno = 2" error msg

Stefano Melchior stefano.melchior at openlabs.it
Fri Feb 17 16:31:18 UTC 2006

On Fri, Feb 17, 2006 at 03:05:28PM +0100, Blaisorblade wrote:
Hi all,
have you ever experience this issue?
> > > > If you use the 2.4.x uml kernel the UML image work fine with network,
> > > > but if you use an available 2.6.x uml image or a 2.6.x image of mine
> > > > the uml bootstrap phase hangs with the following error message:
> > >
> > > Indeed on the same machine and with same config? It's strange, I never
> > > saw
> > yes, first I tried my own configuration, then I downloaded a prebuild uml
> > kernel from http://uml.nagafix.co.uk/ and I tried with this one. Same
> > error again.
> > Then I extracted the configuration from that image and I rebuild with that
> > config, same error for the same problem.
> > ste at etinarcadiaego{~}$ ll /usr/lib/uml/uml_net
> > -rwsr-x---  1 root uml-net 19836 2004-04-15 03:03 /usr/lib/uml/uml_net
> Ok, thanks for this informative info. This is the solution.
> In short, echo $PATH | grep  /usr/lib/uml, and if needed man 3 execvp, could 
> enlighten you... or even the fact that I do:
> # ls -l /usr/bin/uml_net
> -rws--x--x  1 root root 22856 16 feb 18:49 /usr/bin/uml_net
> if you want the full story, instead, IOW:
> Debian has his own very non-standard packaging for uml_utilities, and patches 
> UML to cope with it. For instance, uml_switch has different defaults on UML 
> (the socket goes into /var/run instead of /tmp, in UML).
> And (but this is the first time I hear this) you have uml_net in /usr/lib/uml 
> rather than /usr/bin. Which would be a better choice, btw... but isn't 
> implemented in mainline (we maybe should).

regarding the debian-policy, is there any concern in moving uml_net from
/usr/lib/uml to /usr/bin/? you can find uml_moo, uml_cow, ... all in the
> > Another info: I used either the kernel.org sources and the debian's
> > linux-source(s).
> But you're using a vanilla UML without the forward ports of all 2.4 patches 
> (you're using linux-source(s), not a possible uml-linux-source(s)).
> For the future packaging: I do believe that Debian's defaults have been 
> actually planned while uml_utilities haven't, so I like the idea of switching 
> to Debian paths as defaults, and possibly using the current ones as 
> fallbacks.

If so, what is the most convenient approach?



Stefano Melchior, GPG key = D52DF829 - <stefano.melchior at openlabs.it>
http://etinarcadiaego.dyndns.org    --     http://www.stex.name
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 307 bytes
Desc: Digital signature
Url : http://lists.alioth.debian.org/pipermail/pkg-uml-devel/attachments/20060217/45bf63ff/attachment.pgp

More information about the Pkg-uml-devel mailing list