Bug#384881: [Pkg-uml-pkgs] Bug#384881: provide amd64 build of user-mode-linux

Mattia Dongili malattia at linux.it
Tue Sep 5 06:54:11 UTC 2006

Hi there Ardo!

On Tue, September 5, 2006 5:20 am, Ardo van Rangelrooij said:
> Mattia Dongili (malattia at linux.it) wrote:
>> Hello!
>> Ardo: it seems very similar to your old diff (a couple of months ago),
>> have you benn able to go further with the amd64 experiment?
> I played some more with this evening.  I got quite a lot further, but it
> still
> didn't make it through a successful rootstrap run: It hung at the 'sync'
> step

"hung" as in "it sits there forever"? oooh so sad... this is not very easy
to debug then.

> in debootstrap most of the times, but occaisionally I had it hung already
> some
> time earlier during the package unpack/install/configure.

Hummm... things to check/try out popping out of my head:
- /dev/shm usage (use df -h), if it goes low (very low) increase it
- set debug=true, put an "exit 1" before debootstrap then run debootstrap
manually from the provided shell (well... probably not that useful), be
careful, no Ctrl-C there :)
- start uml_mconsole and send a sysrq+t and see who is hung and where
- add "set -x" to all rootstrap modules :)
- strace deboostrap in the "debian" module

> I've been using the latest user-mode-linus and rootstrap 3.22.  Later this
> week I'll try with rootstrap 3.23.  Let's see whether that makes a
> difference.

eh, I don't think it'll change that much, but let's see.

> I wish there was a way to get somore debugging going...

me too :)

Thanks a lot

More information about the Pkg-uml-pkgs mailing list