[Pkg-utopia-maintainers] Bug#501662: hal: incorrect upgrade management for removal of runlevel links

Kel Modderman kel at otaku42.de
Sat Oct 18 11:21:22 UTC 2008

On Thursday 09 October 2008 21:52:47 Martin Pitt wrote:
> > if dpkg --compare-versions "$2" lt "0.5.11-5"; then
> This must be "lt-nl".
> > 	update-rc.d -f hal remove
> > fi
> That's too blunt. It should at most rm -f the rc{0,6}.d symlinks
> instead of completely stomping over any customizations the admin might
> have done.

Hey Martin,

I just noticed acpid applied a similar patch (#495544) which was a product of
the TearDown work, and it also didn't handle the upgrade path (#502613, CC'd).

What's the best way to proceed here to get these TearDown patches to make
change on upgrade too before too many patches get applied in Debian that do
not take care of it?

I didn't get a reply from my last mail to Michael about how hal package plans
to fix it, is the current best method to do a:

if dpkg --compare-versions "$installed" lt-nl "$version"; then
	rm -f /etc/rc[06].d/K??$script


If possible I would like to supply good working patches to bug reports which
add the ability to handle upgrade path when dropping runlevel links, so we
need an agreement on what that method is, and apply it to all similar

Thanks, Kel.

More information about the Pkg-utopia-maintainers mailing list