[Pkg-utopia-maintainers] Bug#532499: policykit-gnome: Doesn't work directly with sudo

Ghent ghent.debian at gmail.com
Tue Jun 9 17:14:21 UTC 2009

Package: policykit-gnome
Version: 0.9.2-2
Severity: minor

I don't know if it's for policykit or policykit-gnome package.
When I install this package, I can't identify me and the unlock button of gnome-utils package doesn't work (The button isn't grey, but when I type my password => nothing).
To work, I must add this line in /etc/Policykit/Policykit.conf (My user is in the group 'adm') :

<define_admin_auth group="adm"/>

A check should be done during the installation of the package to add a line of this type if the user use sudo.

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (990, 'testing'), (930, 'testing-proposed-updates'), (910, 'stable'), (890, 'stable'), (880, 'proposed-updates'), (80, 'unstable'), (60, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.26-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages policykit-gnome depends on:
ii  dbus-x11                     1.2.12-1    simple interprocess messaging syst
ii  libc6                        2.9-12      GNU C Library: Shared libraries
ii  libdbus-1-3                  1.2.12-1    simple interprocess messaging syst
ii  libdbus-glib-1-2             0.80-4      simple interprocess messaging syst
ii  libgconf2-4                  2.26.0-1    GNOME configuration database syste
ii  libglib2.0-0                 2.20.1-2    The GLib library of C routines
ii  libgtk2.0-0                  2.16.1-2    The GTK+ graphical user interface 
ii  libpango1.0-0                1.24.0-3+b1 Layout and rendering of internatio
ii  libpolkit-dbus2              0.9-3       library for accessing PolicyKit vi
ii  libpolkit-gnome0             0.9.2-2     PolicyKit-gnome library
ii  libpolkit-grant2             0.9-3       library for obtaining privileges v
ii  libpolkit2                   0.9-3       library for accessing PolicyKit
ii  policykit                    0.9-3       framework for managing administrat

policykit-gnome recommends no packages.

policykit-gnome suggests no packages.

-- no debconf information

More information about the Pkg-utopia-maintainers mailing list