Bug#340037: vim-common has circular Depends on vim

Bill Allombert ballombe at debian.org
Sun Nov 20 15:41:29 UTC 2005

Package: vim-common
Version: 1:6.4-001+2
Severity: important

Hello Debian VIM Maintainers,

There is a circular dependency between vim-common and vim:

vim-common:Depends: vim (>> 1:6.3)
vim:Depends: vim-common (= 1:6.4-001+2)

Circular dependencies known to cause problems during upgrade, so we
should try to get rid of them.

Since vim-common is a data package, it is quite likely it does not need
actually to depend on vim and removing this dependency would
remove the circular dependency, so I would suggest you do so.

See threads 


More information about the pkg-vim-maintainers mailing list