Bug#381526: vim: undeclared conflict with vim-doc

Stepan Golosunov stepan at golosunov.pp.ru
Sat Aug 12 04:34:46 UTC 2006

On Fri, Aug 11, 2006 at 08:48:51PM +0200, Norbert Tretkowski wrote:
> * Stepan Golosunov wrote:
> > Vim has undeclared file conflict with vim-doc 1:6.3-071+1sarge1 on
> > /usr/share/doc/vim which breaks upgrades from sarge.
> What's the error message? I just tried to reproduce your problem and
> did an upgrade in a sarge chroot, but don't see a problem.

This is the actual output of dpkg with half of the Russian letters
destroyed by screendump:

Reading changelogs...
����e�e��e �a��o�o� �� �a�e�o�: 100%
�pe��ap��e���a��ac�po��a �a�e�o� ...
(��e��e �a�� �a���x... �a �a���� �o�e�� yc�a�o��e�o 297816 �a��o� �
�o��o�o��a � �a�e�e �a�e�a vim 1:6.3-071+1sarge1 (�c�o���ye�c��a��
Pac�a�o���ae�c��a�e�a ����a�e�a vim...
dpkg: �e y�a�oc� o�pa�o�a�� �apa�e�p
386.deb (--unpack):
 �o����a �epe�a��ca�� /usr/share/doc/vim, �o�op�� y�e ��ee�c�� �a�e�e

Which corresponds to
"trying to overwrite `/usr/share/doc/vim', which is also in package vim-doc".

This came in the middle of xfree86->xorg upgrade and was solved
by removing vim and installing it later.

Dpkg was trying to unpack vim with its /usr/share/doc/vim symlink before
vim-doc, while /usr/share/doc/vim was registered as a directory belonging
to vim-doc (also it was rm -rf'ed by vim.preinst).

Dpkg was already upgraded to the etch version, aptitude was not.

More information about the pkg-vim-maintainers mailing list