[Pkg-virtualbox-devel] Bug#448347: Please try again

Michael Meskes meskes at debian.org
Sat Jan 5 21:03:12 UTC 2008

On Fri, Jan 04, 2008 at 04:54:46PM +0100, Julien Valroff wrote:
> > Could you please try again with 1.5.4-dfsg-1? There were some changes
> > mad to virtualbox that might effect the behaviour you're seeing.
> You are right, this version does fix the issue, I thus close the bug.

Let me just explain what happened. VBox 1.5.2 had a typo that made it
load libhal.so which of course is only installed if you install the
libhal-dev package. When I read that they fixed this typo to read
libhal.so.1 I thought it might fix your problem too, which is
fortunately did. We all didn't notice because we had libhal-dev
installed which is needed to build virtualbox-ose.

Which brings up one other thought, namely that virtualbox does work
without libhal, but should have libhal installed. Also it shows that
virtualbox does not directly link to libhal. Thus I added it as
recommended, which will hopefully make sure that a similar situation
doesn't come up again.

Michael Meskes
Email: Michael at Fam-Meskes dot De, Michael at Meskes dot (De|Com|Net|Org)
ICQ: 179140304, AIM/Yahoo: michaelmeskes, Jabber: meskes at jabber.org
Go VfL Borussia! Go SF 49ers! Use Debian GNU/Linux! Use PostgreSQL!

More information about the Pkg-virtualbox-devel mailing list