Bug#376512: Installation of asterisk-classic- fails on a fresh Etch system

Alessandro Polverini alex at nibbles.it
Mon Jul 3 11:40:08 UTC 2006

Package: asterisk-classic
Version: 1:
Severity: normal

This is the error I get trying to install latest package on a freshly installed Etch system:

Setting up asterisk-config ( ...
adduser: Warning: The home dir you specified already exists.
Adding system user `asterisk' with uid 103...
Adding new group `asterisk' (107).
Adding new user `asterisk' (103) with group `asterisk'.
The home directory `/var/lib/asterisk' already exists.  Not copying from `/etc/skel'
adduser: Warning: that home directory does not belong to the user you are currently creating
Adding user `asterisk' to group `audio'...
Adding user `asterisk' to group `dialout'...
chown: cannot access `/var/run/asterisk': No such file or directory
dpkg: error processing asterisk-config (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of asterisk-classic:
 asterisk-classic depends on asterisk-config (= 1: | asterisk-config-custom; however:
  Package asterisk-config is not configured yet.
  Package asterisk-config-custom is not installed.
dpkg: error processing asterisk-classic (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (500, 'testing'), (50, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.16-2-k7
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

Versions of packages asterisk-classic depends on:
ii  adduser                 3.87             Add and remove users and groups
pn  asterisk-config | aster <none>           (no description available)
ii  asterisk-sounds-main    1: sound files for asterisk
ii  libasound2              1.0.11-7         ALSA library
ii  libc6                   2.3.6-15         GNU C Library: Shared libraries
ii  libcomerr2              1.39-1           common error description library
ii  libcurl3                7.15.4-1         Multi-protocol file transfer libra
ii  libgsm1                 1.0.10-13        Shared libraries for GSM speech co
ii  libidn11                0.6.3-1          GNU libidn library, implementation
ii  libkrb53                1.4.3-7          MIT Kerberos runtime libraries
ii  libncurses5             5.5-2            Shared libraries for terminal hand
ii  libnewt0.52             0.52.2-4         Not Erik's Windowing Toolkit - tex
ii  libpopt0                1.10-2           lib for parsing cmdline parameters
ii  libpq4                  8.1.4-2          PostgreSQL C client library
ii  libpri1.2               1.2.3-1          Primary Rate ISDN specification li
ii  libspeex1               1.1.12-2         The Speex Speech Codec
ii  libsqlite0              2.8.16-1         SQLite shared library
ii  libssl0.9.8             0.9.8b-2         SSL shared libraries
ii  libtonezone1            1:1.2.6-2        tonezone library (runtime)
ii  unixodbc                2.2.11-13        ODBC tools libraries
ii  zlib1g                  1:1.2.3-11       compression library - runtime

asterisk-classic recommends no packages.

-- no debconf information

More information about the Pkg-voip-maintainers mailing list