Asterisk: multiple vulnerabilities

Tzafrir Cohen tzafrir.cohen at
Sat Aug 18 03:36:56 UTC 2007

On Sat, Aug 18, 2007 at 12:15:15PM +1000, Steffen Joeris wrote:
> Hi

> As you know the build-dep on libzapp-dev is missing. How do you want to build 
> the package on all the buildds? 

As I noted in my answer to the previous thread, the problem is not the
missing libzap (it has not been used at all for building Asterisk, even
in Sarge, and has been accidentally left as a build dependency). That
build-dep could be dropped.

The problem is that the package zaptel-source (built from the source
package zaptel) places zaptel.h in /usr/include/zaptel rather than
/usr/include/linux . This is part of the change of Zaptel 1.4 .

Now that libpri has made it out of the new queue, I think it is a good
time to upload our new zaptel, right? Mark?

That said, I see really no point in supporting Asterisk 1.2 on Lenny.
Asterisk 1.4 is by now stable and the officially-blessed version by
upstream. We should not waste too many efforts on trying to maintain an
obsolete version in Testing. What exactly is stopping the Sid package of
Asterisk from getting into Lenny?

               Tzafrir Cohen       
icq#16849755                    jabber:tzafrir at
+972-50-7952406           mailto:tzafrir.cohen at  iax:guest at

More information about the Pkg-voip-maintainers mailing list