Bug#439197: Build-depends libpri-dev version not specific enough
paravoid at debian.org
Thu Aug 23 10:44:58 UTC 2007
Martijn Grendelman wrote:
> One more thing: even though the build-dep is updated, the binary
> asterisk package that is built, still gets a "Depends: libpri1.0
> (>=1.4)", so one can upgrade Asterisk without upgrading libpri. I
> haven't tested this, but I imagine that this could break things.
Actually, no it wouldn't.
The binary package name was changed to libpri1.0 (from libpri1.2) in
So, there is no libpri1.0 that could fulfill this dependency without
providing a bristuffed libpri.
> The actual problem is in the libpri package, that ships a 'shlibs' file
> with this version. Perhaps I should file a bug against libpri?
FWIW, In any other case you would be right.
More information about the Pkg-voip-maintainers