libpri1, libpri1.2, SONAMES etc.

Tzafrir Cohen tzafrir.cohen at
Fri Jul 27 23:09:40 UTC 2007

On Fri, Jul 27, 2007 at 12:26:56AM +0300, Tzafrir Cohen wrote:

> Keving Flemming believes otherwise:
> from #asterisk-dev a while ago:
> <tzafrir_laptop> 
> BTW: what exactly is the compatibility status between
> libpri in asterisk 1.0, 1.2 and 1.4?
> the soname is the same, so the directory pretends to be compatible
> This is just now being discussed at the debian
> packagers list: do we need to change the soname and have separate
> packages for 1.2 and 1.4, and can we just keep the single package of 1.4
> <kpfleming> 
> unfortunately it is not compatible, and we do not do a good
> job of naming things properly to deal with that
> there are API differences include differently-sized
> structures between the version

However, after a while Faidon joined the chat. And we noticed that the
changes were not in the public interface.

So I went on to building asterisk 1.2 with libpri 1.4 and zaptel 1.4 .

Required changes:

1. I had to drop the ukcid patch from Asterisk, as its Zaptel
counterpart was not applied. I have reopened and hope to get a version of that patch that
can be merged upstream.

Either we add it to Zaptel or drop it from Asterisk.

2. Added the following symlinks:

  /usr/include/linux/zaptel.h -> ../zaptel/zaptel.h
  /usr/include/tonezone.h -> zaptel/tonezone.h

Add those two to zaptel-source and libtonezone-dev.

3. Re-add bristuff support to libpri.

I have set USE_BRISTUFF=1 in the rules file. Then re-added the patch
libname.dpatch (needed some updating) and updated the bristuff patch.

This should not break the libpri package, so it can be safely commited.
But if you want a libpri package out now without any changes then I'll
hold my commits.

               Tzafrir Cohen       
icq#16849755                    jabber:tzafrir at
+972-50-7952406           mailto:tzafrir.cohen at  iax:guest at

More information about the Pkg-voip-maintainers mailing list